Update nodejs to v8.12.0

Updating node_modules dependencies to be compatible with nodejs
v8.12.0. Also modified .gitignore to include a mock mobmonitor
backend needed for e2e tests.

CQ-DEPEND=CL:1513496
BUG=None
TEST=e2e/run_e2e.sh; ng test --single-run

Change-Id: I8f8903b8734f701d83d2ef2326ca4f9ecb17a4a0
Reviewed-on: https://chromium-review.googlesource.com/1311133
Commit-Ready: ChromeOS CL Exonerator Bot <chromiumos-cl-exonerator@appspot.gserviceaccount.com>
Tested-by: Keith Haddow <haddowk@chromium.org>
Reviewed-by: Keith Haddow <haddowk@chromium.org>
Reviewed-by: Matt Mallett <mattmallett@chromium.org>
4 files changed