Add workaround for firmware <= 0.6.7

When polling diagnostics, the device can get in a bad state if we don't
rate limit the polling. This workaround can be removed when this is
fixed in the firmware.

BUG=none
TEST=Built successfully for guado

Change-Id: I854a032741b41ae2aebfb156aa3412499e606342
Signed-off-by: Emil Lundmark <emil@limesaudio.com>
Reviewed-on: https://chromium-review.googlesource.com/497435
Reviewed-by: Simon Que <sque@chromium.org>
1 file changed
tree: 6f3a4322ea0e41bad11143b9402fe31c261349ae
  1. .clang-format
  2. .clang-tidy
  3. .gitignore
  4. CMakeLists.txt
  5. LICENSE.md
  6. PRESUBMIT.cfg
  7. README.md
  8. conf/
  9. src/
README.md

atrusctl

This tool is used to interact with an Atrus device.

Requirements

The GNU C Library, libusb 1.0 and libudev are required. GNU C is required because the program utilizes argp.

Building

CMake is used for building the application.

Here is an example of how to build:

$ mkdir build/
$ cd build/
$ cmake ..
$ make

You can also install it on your machine by running:

$ make install

Using

Run the following to see the help section of the application.

$ atrusctl --help

Also, make sure you have read and write access to the USB device. This may be done by, e.g., setting appropriate udev rules.

License

Individual files are tagged with SPDX-License-Identifier to indicate its license instead of including the full license text. See the SPDX License List for more information.