Servo V3: Add version specific interface to params

This change allows params to specify an interface depending on servo
versions. This is required by servoflex_v2_r0_p50 as the pca9534
chip is on a separate i2c bus than the other gpio expanders.

BUG=chromium:268611
TEST=local setup with spring. Tested toggling spi2_buf_on_flex_en.
Ensured servo_v2 still works.

CQ-DEPEND=If4c77c7c654ef1b2ecb39e720b2b6d5a7cb9a41c
Change-Id: Ic6d706b73ade074bb597a40c8c5df62dc2eaa99f
Reviewed-on: https://gerrit.chromium.org/gerrit/64969
Reviewed-by: Todd Broch <tbroch@chromium.org>
Commit-Queue: Simran Basi <sbasi@chromium.org>
Reviewed-by: Simran Basi <sbasi@chromium.org>
Tested-by: Simran Basi <sbasi@chromium.org>
3 files changed