Clone this repo:
  1. c1a22e7 Limit logitech-updater to process single Logitech cfm device only by Sanjay Sheth · 2 weeks ago master
  2. 18a308b logitech-updater: use base::NumberToString. by Qijiang Fan · 3 weeks ago
  3. 7a04522 Fix ToT clang warning by Manoj Gupta · 3 months ago factory-drallion-13080.B release-R82-12974.B release-R83-13020.B release-R84-13099.B stabilize-12997.B stabilize-13020.55.B stabilize-13020.67.B stabilize-sylas-13019.B
  4. 136c962 Disable logitech-updater for all Logitech devices by Joe Tessler · 4 months ago firmware-drallion-12930.B stabilize-12951.B stabilize-volteer-12931.B
  5. 2e45dd0 Give Logitech Rally Mic a semi-unique ALSA id to prevent conflicts. by ChromeOS Developer · 4 months ago

logitech-updater is a utility to upgrade logitech camera firmwares.

Requirements

The GNU C/C++ library is required.

Building

At the top level of the directory.

$ make

Alternatively at Chromium OS development environment,

$ emerge-${BOARD} logitech-updater

How to use

logitech updater currently includes the follow executables: ptzpro2-updater
$ ptzpro2-updater -h