mimo-updater: use unversioned libchrome libraray.

Libchrome is changing pkg-config and .so library name from
xxxx-${libbase_ver}.{pc,so} to xxx.{pc,so}.

Libchrome uprev rebuild will be handled by ebuild subslot change. And
there's no need to install multiple libchrome. Keeping libbase_ver
suffix will cause troubles on linking libraries when developers wants to
test locally emerge a-single-package without build_packages, after a
libchrome uprev. Especially in a case a package depends on another
package(library), and both depends on libchrome. Thus, removing
libbase_ver from suffix.

BUG=chromium:920513
TEST=CQ

Change-Id: I8952f2e9df31a55ede9e5919ad372ed12b503e8f
Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/third_party/mimo-updater/+/2505329
Reviewed-by: Joe Tessler <jrt@chromium.org>
Commit-Queue: Qijiang Fan <fqj@google.com>
Tested-by: Qijiang Fan <fqj@google.com>
1 file changed
tree: a3cb478061b604cc9de0d075ccc2a5645f6ff6ad
  1. LICENSE
  2. Makefile
  3. OWNERS
  4. README.md
  5. common.mk
  6. conf/
  7. mimo_fw_updater.cc
README.md

MIMO-updater is a utility to upgrade the displaylink FW in the MIMO device.

Requirements

The GNU C/C++ library and libusb 1.0 are required.

Building

At the top level of the directory.

$ make

Alternatively at Chromium OS development environment,

$ emerge-${BOARD} mimo-updater

How to use

$ mimo-updater $${FW file name}