raise an AttributeError for six.moves.X when X is a module not available in the current interpreter

As discussed in https://github.com/pypa/pip/issues/1643.
3 files changed