Prepare for dartdoc 6.2.0 release (#3355)

diff --git a/CHANGELOG.md b/CHANGELOG.md
index f2a6319..14f1191 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,7 @@
-## 6.2.0-dev
+## 6.2.0
 
+* Add basic support for Dart 3.0 features, including records and class
+  modifiers.  (#3340, #3354)
 * Stop generating a null-safety badge for elements in a null-safe library.
   (#3295)
 * Use a sun icon for switching to the light theme. (#3309)
diff --git a/dartdoc_options.yaml b/dartdoc_options.yaml
index 38a3d4f..b9401fc 100644
--- a/dartdoc_options.yaml
+++ b/dartdoc_options.yaml
@@ -1,4 +1,4 @@
 dartdoc:
   linkToSource:
     root: '.'
-    uriTemplate: 'https://github.com/dart-lang/dartdoc/blob/v6.2.0-dev/%f%#L%l%'
+    uriTemplate: 'https://github.com/dart-lang/dartdoc/blob/v6.2.0/%f%#L%l%'
diff --git a/lib/src/version.dart b/lib/src/version.dart
index 9f803a1..9a6891c 100644
--- a/lib/src/version.dart
+++ b/lib/src/version.dart
@@ -1,2 +1,2 @@
 // Generated code. Do not modify.
-const packageVersion = '6.2.0-dev';
+const packageVersion = '6.2.0';
diff --git a/pubspec.yaml b/pubspec.yaml
index f91af90..b26a65e 100644
--- a/pubspec.yaml
+++ b/pubspec.yaml
@@ -1,6 +1,6 @@
 name: dartdoc
 # Run `dart run grinder build` after updating.
-version: 6.2.0-dev
+version: 6.2.0
 description: A non-interactive HTML documentation generator for Dart source code.
 repository: https://github.com/dart-lang/dartdoc
 
@@ -8,36 +8,37 @@
   sdk: '>=2.18.0 <3.0.0'
 
 dependencies:
-  analyzer: ^5.2.0
+  analyzer: ^5.7.1
   args: ^2.3.0
   cli_util: ^0.3.5
-  collection: ^1.15.0
+  collection: ^1.17.0
   crypto: ^3.0.1
-  glob: ^2.0.1
+  glob: ^2.1.1
   html: ^0.15.0
   logging: ^1.0.2
   markdown: ^7.0.0
   meta: ^1.7.0
   package_config: ^2.0.2
   path: ^1.8.0
-  pub_semver: ^2.1.0
+  pub_semver: ^2.1.3
   source_span: ^1.8.1
   yaml: ^3.1.0
 
 dev_dependencies:
   async: ^2.8.2
-  build: ^2.1.0
-  build_runner: ^2.1.2
-  build_test: ^2.1.3
-  build_version: ^2.1.0
-  code_builder: ^4.2.0
+  build: ^2.3.1
+  build_runner: ^2.3.0
+  build_test: ^2.1.6
+  build_version: ^2.1.1
+  code_builder: ^4.4.0
   coverage: ^1.0.3
   dart_style: ^2.2.0
   grinder: ^0.9.0
   http: ^0.13.3
   js: ^0.6.5
   lints: ^2.0.0
-  test: ^1.19.0
+  matcher: ^0.12.14
+  test: ^1.23.1
   test_descriptor: ^2.0.0
   test_process: ^2.0.2
   test_reflective_loader: ^0.2.0