Removed fixed dependencies

The fixed analyzer and dart_style dependencies were conflicting with the
one required from other packages

Related https://github.com/dart-lang/observatory_pub_packages/commit/0e74202dd671265f12a3c80d223717b393f4feb9

R=rmacnak@google.com

Review-Url: https://codereview.chromium.org//2990843002 .
609 files changed
tree: 2531498a72fc40a8be2ba7cb6e73cc3944f9fb92
  1. README.md
  2. codereview.settings
  3. packages/
  4. pubspec.yaml
  5. roll.py
README.md

Snapshot of Observatory pub package dependencies needed to build

The pubspec.yaml in this repository is the source of truth