Seems exporting oauth2 isnt needed (#2155)

diff --git a/lib/src/oauth2.dart b/lib/src/oauth2.dart
index 6a6e48d..50b7bd5 100644
--- a/lib/src/oauth2.dart
+++ b/lib/src/oauth2.dart
@@ -16,8 +16,6 @@
 import 'system_cache.dart';
 import 'utils.dart';
 
-export 'package:oauth2/oauth2.dart';
-
 /// The pub client's OAuth2 identifier.
 final _identifier = '818368855108-8grd2eg9tj9f38os6f1urbcvsq399u8n.apps.'
     'googleusercontent.com';