Moved pkg pubspecs to use dev_dependencies where appropriate

BUG=https://code.google.com/p/dart/issues/detail?id=9309

Review URL: https://codereview.chromium.org//12962003

git-svn-id: https://dart.googlecode.com/svn/branches/bleeding_edge/dart/pkg/yaml@20285 260f80e4-7a28-3924-810f-c04153c831b5
1 file changed
tree: 832bb2f913da21c98cb692065602cd5dded031ca
  1. README.md
  2. lib/
  3. pubspec.yaml
  4. test/
README.md

A parser for YAML.

Use loadYaml to load a single document, or loadYamlStream to load a stream of documents. For example:

import 'package:yaml/yaml.dart';
main() {
  var doc = loadYaml("YAML: YAML Ain't Markup Language");
  print(doc['YAML']);
}

This library currently doesn't support dumping to YAML. You should use stringify from dart:json instead:

import 'dart:json' as json;
import 'package:yaml/yaml.dart';
main() {
  var doc = loadYaml("YAML: YAML Ain't Markup Language");
  print(json.stringify(doc));
}

The source code for this package is at http://code.google.com/p/dart. Please file issues at http://dartbug.com. Other questions or comments can be directed to the Dart mailing list at mailto:misc@dartlang.org.