Fix yaml's SDK constraint to contain only SDKs with MapMixin.

R=rnystrom@google.com
BUG=19200

Review URL: https://codereview.chromium.org//312163003

git-svn-id: https://dart.googlecode.com/svn/branches/bleeding_edge/dart/pkg/yaml@37024 260f80e4-7a28-3924-810f-c04153c831b5
1 file changed
tree: b852f52f8d177ed05b87f716cf29bf86f67e80a5
  1. CHANGELOG.md
  2. LICENSE
  3. README.md
  4. lib/
  5. pubspec.yaml
  6. test/
README.md

A parser for YAML.

Use loadYaml to load a single document, or loadYamlStream to load a stream of documents. For example:

import 'package:yaml/yaml.dart';

main() {
  var doc = loadYaml("YAML: YAML Ain't Markup Language");
  print(doc['YAML']);
}

This library currently doesn't support dumping to YAML. You should use JSON.encode from dart:convert instead:

import 'dart:convert';
import 'package:yaml/yaml.dart';

main() {
  var doc = loadYaml("YAML: YAML Ain't Markup Language");
  print(JSON.encode(doc));
}

The source code for this package is at http://code.google.com/p/dart. Please file issues at http://dartbug.com. Other questions or comments can be directed to the Dart mailing list at mailto:misc@dartlang.org.