Release 0.2.4

- Corrects minimal version requirements of dependency `rayon`.

744c24117572563a98a7e9168a5ac1ee4a1ca7f702211258797bbe0ed0346c3c  target/package/jpeg-decoder-0.2.4.crate
Release notes for 0.2.4
2 files changed
tree: c342bbad597afacb46b8e4114271aa4fbe9573ed
  1. .github/
  2. benches/
  3. examples/
  4. fuzz/
  5. fuzz-afl/
  6. src/
  7. tests/
  8. .gitignore
  9. appveyor.yml
  10. Cargo.toml
  11. CHANGELOG.md
  12. LICENSE-APACHE
  13. LICENSE-MIT
  14. README.md
  15. rust-toolchain
README.md

jpeg-decoder

Rust CI AppVeyor Build Status Crates.io

A Rust library for decoding JPEGs.

Documentation

Example

Cargo.toml:

[dependencies]
jpeg-decoder = "0.2"

main.rs:

extern crate jpeg_decoder as jpeg;

use std::fs::File;
use std::io::BufReader;

fn main() {
    let file = File::open("hello_world.jpg").expect("failed to open file");
    let mut decoder = jpeg::Decoder::new(BufReader::new(file));
    let pixels = decoder.decode().expect("failed to decode image");
    let metadata = decoder.info().unwrap();
}

Requirements

This crate compiles with rust >= 1.48. Minimum Supported Rust Version:

  • All releases 0.1.* compile with rust >= 1.36.
  • The releases 0.2.* may bump Rust Version requirements (TBD).