Updated Netty to version 4.1.9.Final

14 files changed
tree: d078839523de759e589323cdc5a3586a32fbf2d4
  2. LICENSE.txt
  3. NOTICE.txt
  4. README.md
  5. jar/
  6. javadoc/
  7. license/

Netty Project

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients.


How to build

For the detailed information about building and developing Netty, please visit the developer guide. This page only gives very basic information.

You require the following to build Netty:

Note that this is build-time requirement. JDK 5 (for 3.x) or 6 (for 4.0+) is enough to run your Netty-based application.

Branches to look

Development of all versions takes place in each branch whose name is identical to <majorVersion>.<minorVersion>. For example, the development of 3.9 and 4.0 resides in the branch ‘3.9’ and the branch ‘4.0’ respectively.