blob: de4bbc0a9d64b44dfa6fbb836f9753b47e28ac69 [file] [log] [blame]
apply plugin: 'com.android.library'
apply plugin: org.robolectric.gradle.AndroidProjectConfigPlugin
android {
compileSdkVersion 29
defaultConfig {
minSdkVersion 16
targetSdkVersion 29
}
compileOptions {
sourceCompatibility = '1.8'
targetCompatibility = '1.8'
}
testOptions {
unitTests {
includeAndroidResources = true
}
}
}
dependencies {
implementation("androidx.appcompat:appcompat:1.0.0")
// Testing dependencies
testImplementation project(path: ':testapp', configuration: 'default')
testImplementation project(":robolectric")
testImplementation "junit:junit:4.13.1"
testImplementation("androidx.test:core:1.3.0-rc03")
testImplementation("androidx.core:core:1.1.0-alpha05")
testImplementation("androidx.test:runner:1.3.0-rc03")
testImplementation("androidx.test:rules:1.3.0-rc03")
testImplementation("androidx.test.espresso:espresso-intents:3.3.0-rc03")
testImplementation("androidx.test.espresso:espresso-core:3.3.0-rc03")
testImplementation("androidx.test.ext:truth:1.3.0-rc03")
// TODO: this should be a transitive dependency of core...
testImplementation("androidx.lifecycle:lifecycle-common:2.0.0")
testImplementation("androidx.test.ext:junit:1.1.2-rc03")
testImplementation("com.google.truth:truth:1.0.1")
}