Choose Ubuntu-14.04 instead of Ubuntu.

There are Ubuntu-12.04 bot, and it cannot build goma client because
clang used for the build requires libstdc++ >= 3.4.19.

Bug: 862906
Change-Id: If04c2fd81e7d72a4919f51cf94e3896c27ab3540
1 file changed