blob: 46658ce43f86138e997682c8b9ae45cb294c5705 [file] [log] [blame]
# vpython VirtualEnv installation package for Recipe Engine.
python_version: "2.7"
verify_pep425_tag: [
{python: "cp27", abi: "cp27mu", platform: "manylinux1_x86_64"},
{python: "cp27", abi: "cp27mu", platform: "linux_arm64"},
{python: "cp27", abi: "cp27mu", platform: "linux_armv6l"},
{python: "cp27", abi: "cp27m", platform: "macosx_10_10_intel"},
{python: "cp27", abi: "cp27m", platform: "win32"},
{python: "cp27", abi: "cp27m", platform: "win_amd64"}
]
wheel: <
name: "infra/python/wheels/coverage/${vpython_platform}"
version: "version:5.5"
>
# Argparse is in python stdlib... but! Old versions of python 2.7 have versions
# of this with bugs. This version is bug-free (well... it doesn't have any bugs
# that we care about).
wheel: <
name: "infra/python/wheels/argparse-py2_py3"
version: "version:1.4.0"
>
##
# BEGIN "cryptography" dependencies.
##
wheel: <
name: "infra/python/wheels/cryptography/${vpython_platform}"
version: "version:3.3.1"
>
wheel: <
name: "infra/python/wheels/appdirs-py2_py3"
version: "version:1.4.3"
>
wheel: <
name: "infra/python/wheels/enum34-py2"
version: "version:1.1.6"
>
wheel: <
name: "infra/python/wheels/idna-py2_py3"
version: "version:2.5"
>
wheel: <
name: "infra/python/wheels/ipaddress-py2"
version: "version:1.0.18"
>
wheel: <
name: "infra/python/wheels/packaging-py2_py3"
version: "version:16.8"
>
wheel: <
name: "infra/python/wheels/pyasn1-py2_py3"
version: "version:0.2.3"
>
wheel: <
name: "infra/python/wheels/pyopenssl-py2_py3"
version: "version:17.2.0"
>
wheel: <
name: "infra/python/wheels/pyparsing-py2_py3"
version: "version:2.2.0"
>
wheel: <
name: "infra/python/wheels/setuptools-py2_py3"
version: "version:34.3.2"
>
wheel: <
name: "infra/python/wheels/six-py2_py3"
version: "version:1.15.0"
>
##
# END "cryptography" dependencies.
##
wheel: <
name: "infra/python/wheels/urllib3-py2_py3"
version: "version:1.22"
>
wheel: <
name: "infra/python/wheels/requests-py2_py3"
version: "version:2.13.0"
>
wheel: <
name: "infra/python/wheels/protobuf-py2_py3"
# NOTE: This MUST have a matching version of:
# infra/tools/protoc/${{platform}}
version: "version:3.15.8"
>
wheel: <
name: "infra/python/wheels/astunparse-py2_py3"
version: "version:1.5.0"
>
wheel: <
name: "infra/python/wheels/mock-py2_py3"
version: "version:2.0.0"
>
wheel: <
name: "infra/python/wheels/funcsigs-py2_py3"
version: "version:1.0.2"
>
wheel: <
name: "infra/python/wheels/pbr-py2_py3"
version: "version:3.0.0"
>
wheel: <
name: "infra/python/wheels/attrs-py2_py3"
version: "version:20.3.0"
>
wheel: <
name: "infra/python/wheels/scandir/${vpython_platform}"
version: "version:1.9.0"
>
## Gevent
wheel: <
name: "infra/python/wheels/gevent/${vpython_platform}"
version: "version:1.4.0"
>
wheel: <
name: "infra/python/wheels/greenlet/${vpython_platform}"
version: "version:0.4.15"
>
wheel: <
name: "infra/python/wheels/cffi/${vpython_platform}"
version: "version:1.14.5"
>
wheel: <
name: "infra/python/wheels/pycparser-py2_py3"
version: "version:2.19"
>
wheel: <
name: "infra/python/wheels/psutil/${vpython_platform}"
version: "version:5.6.2"
>
wheel: <
name: "infra/python/wheels/pympler-py2_py3"
version: "version:0.8"
>
wheel: <
name: "infra/python/wheels/future-py2_py3"
version: "version:0.18.2"
>
wheel: <
name: "infra/python/wheels/typing-py2"
version: "version:3.6.4"
>
wheel: <
name: "infra/python/wheels/parameterized-py2_py3"
version: "version:0.8.1"
>