libweave: migrate the package to use GN.

Because Cq-Depend is not supported for libweave package
(crbug.com/966234), I should keep
gyp files until libweave ebuild's update (crrev/c/1617059) lands.

TEST=emerge-$BOARD libweave
BUG=chromium:953642

Change-Id: I07e9823516f9cbeaf7dc68830424c16c118706c9
Reviewed-on: https://chromium-review.googlesource.com/c/weave/libweave/+/1617144
Reviewed-by: Keigo Oka <oka@chromium.org>
Reviewed-by: Tatsuhisa Yamaguchi <yamaguchi@chromium.org>
Tested-by: Keigo Oka <oka@chromium.org>
Commit-Queue: Keigo Oka <oka@chromium.org>
2 files changed