blob: f01d0f8454d5e399bd4894992c1286cf1caf4a6b [file] [log] [blame]
# Copyright (c) 2012 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="92bb409ba93356d341fbc25735d2ec9fe114514e"
CROS_WORKON_TREE="d406eb3125c093247c780d13df47a69ad9bcf948"
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME=../third_party/autotest
CROS_WORKON_SUBDIR=files
inherit cros-workon autotest-deponly cros-debug libchrome
DESCRIPTION="Autotest glbench dep"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="*"
# Autotest enabled by default.
IUSE="+autotest X"
RDEPEND="${RDEPEND}
>=dev-cpp/gflags-2.0
media-libs/libpng
!opengles? ( virtual/opengl )
opengles? ( virtual/opengles )
media-libs/waffle
"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers"
AUTOTEST_DEPS_LIST="glbench"
# NOTE: For deps, we need to keep *.a
AUTOTEST_FILE_MASK="*.tar.bz2 *.tbz2 *.tgz *.tar.gz"
src_prepare() {
autotest-deponly_src_prepare
cros-debug-add-NDEBUG
}
src_configure() {
cros-workon_src_configure
}