blob: 5d0230daf3385ff47175372cd5f35985a0fe6c60 [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="92bb409ba93356d341fbc25735d2ec9fe114514e"
CROS_WORKON_TREE="d406eb3125c093247c780d13df47a69ad9bcf948"
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME=../third_party/autotest
CROS_WORKON_SUBDIR=files
inherit arc-build autotest cros-workon flag-o-matic
DESCRIPTION="Public ARC autotests"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
CLIENT_TESTS="
+tests_cheets_StartAndroid
+tests_graphics_Gralloc
"
IUSE_TESTS="${CLIENT_TESTS}"
RDEPEND="
dev-python/pyxattr
chromeos-base/chromeos-chrome
chromeos-base/autotest-chrome
chromeos-base/telemetry
"
DEPEND="${RDEPEND}"
IUSE="
+autotest
${IUSE_TESTS}
"
src_prepare() {
# Telemetry tests require the path to telemetry source to exist in order to
# build. Copy the telemetry source to a temporary directory that is writable,
# so that file removals in Telemetry source can be performed properly.
export TMP_DIR="$(mktemp -d)"
cp -r "${SYSROOT}/usr/local/telemetry" "${TMP_DIR}"
export PYTHONPATH="${TMP_DIR}/telemetry/src/third_party/catapult/telemetry"
autotest_src_prepare
}
src_configure() {
# Use arc-build base class to select the right compiler for native Android code.
arc-build-select-gcc
# The ARC sysroot only has prebuilt 32-bit libraries at this point
case ${ARCH} in
arm)
# Nothing to do in this case
;;
amd64)
append-flags -m32
append-ldflags -m32
;;
esac
}