blob: a423c3d57c79705ee789823944e5424c84764fec [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="92bb409ba93356d341fbc25735d2ec9fe114514e"
CROS_WORKON_TREE="d406eb3125c093247c780d13df47a69ad9bcf948"
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME=../third_party/autotest
CROS_WORKON_SUBDIR=files
inherit cros-workon autotest
DESCRIPTION="shill autotests"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="*"
# Enable autotest by default.
IUSE="+autotest +tpm tpm2"
RDEPEND="
!<chromeos-base/autotest-tests-0.0.3
chromeos-base/shill-test-scripts
"
DEPEND="${RDEPEND}"
IUSE_TESTS="
+tests_network_CheckCriticalProcesses
+tests_network_DefaultProfileCreation
+tests_network_DefaultProfileServices
+tests_network_DestinationVerification
+tests_network_DhcpClasslessStaticRoute
+tests_network_DhcpFailureWithStaticIP
+tests_network_DhcpNak
+tests_network_DhcpNegotiationSuccess
+tests_network_DhcpNegotiationTimeout
+tests_network_DhcpNonAsciiParameter
+tests_network_DhcpRenew
+tests_network_DhcpRenewWithOptionSubset
+tests_network_DhcpRequestHostName
+tests_network_DhcpStaticIP
+tests_network_DhcpVendorEncapsulatedOptions
+tests_network_DhcpWpadNegotiation
+tests_network_ShillInitScripts
+tests_network_TwoShills
+tests_network_WiFiInvalidParameters
+tests_network_WlanDriver
+tests_network_WlanHasIP
tpm? ( +tests_network_VPNConnect )
tpm2? ( +tests_network_VPNConnect )
"
IUSE="${IUSE} ${IUSE_TESTS}"
AUTOTEST_FILE_MASK="*.a *.tar.bz2 *.tbz2 *.tgz *.tar.gz"