blob: 218415c35164f0e3b9b6f76bb8632f0ec67bcec8 [file] [log] [blame]
# Copyright (c) 2011 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
CROS_WORKON_COMMIT="371b69af12a9cb2f27f8e3376e28f7a48d0dc896"
CROS_WORKON_TREE="8ba4aa7159d55dabf6cfd74f23752476793bc91d"
CROS_WORKON_PROJECT="chromiumos/chromite"
CROS_WORKON_LOCALNAME="../../chromite"
CROS_WORKON_OUTOFTREE_BUILD=1
inherit cros-constants cros-workon python
DESCRIPTION="Wrapper for running chromite unit tests"
HOMEPAGE="http://www.chromium.org/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="cros_host"
src_install() {
use cros_host && return
insinto "$(python_get_sitedir)/chromite"
doins -r "${S}"/*
# TODO (crbug.com/346859) Convert to using distutils and a setup.py
# to specify which files should be installed.
cd "${D}/$(python_get_sitedir)/chromite"
find '(' -name '*.pyc' -o -name '*unittest.py' ')' -delete
rm -rf lib/datafiles/
rm -rf third_party/pyelftools/test
rm -rf mobmonitor
}
src_test() {
# Run the chromite unit tests, resetting the environment to the standard
# one using a sudo invocation. Currently the tests assume they run from a
# repo checkout, so they need to be run from the real source dir.
# TODO(davidjames): Fix that, and run the tests from ${S} instead.
cd "${CHROMITE_DIR}/cbuildbot" && sudo -u "${PORTAGE_USERNAME}" \
PATH="${CROS_WORKON_SRCROOT}/../depot_tools:${PATH}" ./run_tests || die
}