blob: bd20a313032104b9b49d81a0ad19f1d3c3e51261 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
CROS_WORKON_COMMIT="2c5fd79b6efa11bac3347b5a5b676014e8336462"
CROS_WORKON_TREE="7c67f93c1d8b648d27face4aeb3c650feb007cfd"
CROS_WORKON_PROJECT="chromiumos/platform/touch_updater"
CROS_WORKON_OUTOFTREE_BUILD=1
inherit cros-workon
DESCRIPTION="Touch firmware and config updater"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="BSD"
SLOT="0"
KEYWORDS="*"
IUSE="input_devices_synaptics
input_devices_wacom
input_devices_st
"
RDEPEND="
input_devices_synaptics? ( chromeos-base/rmi4utils )
input_devices_wacom? ( chromeos-base/wacom_fw_flash )
input_devices_st? ( chromeos-base/st_flash )
"
src_install() {
insinto "/etc/init"
doins "scripts/chromeos-touch-update.conf"
exeinto "/opt/google/touch/scripts"
doexe scripts/*.sh
if [ -d "policies/${ARCH}" ]; then
insinto "/opt/google/touch/policies"
doins policies/${ARCH}/*.policy
fi
}