blob: 9f700d5e1a9a137d373fee87b47c58c7d65c0cd5 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="cfce83f31475fcbfd37a197aad5095ac11826009"
CROS_WORKON_TREE="b5401167840adb9c0ad7aec9fadbf95b56559f9d"
CROS_WORKON_PROJECT="chromiumos/third_party/kernel"
CROS_WORKON_LOCALNAME="kernel/v4.4"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
inherit cros-workon toolchain-funcs
HOMEPAGE="https://www.kernel.org/"
DESCRIPTION="Intel processor C-state and P-state reporting tool"
LICENSE="GPL-2"
SLOT=0
KEYWORDS="*"
IUSE="-asan"
domake() {
emake -C tools/power/x86/turbostat \
BUILD_OUTPUT="$(cros-workon_get_build_dir)" DESTDIR="${D}" \
CC="$(tc-getCC)" "$@"
}
src_configure() {
asan-setup-env
cros-workon_src_configure
}
src_compile() {
domake
}
src_install() {
domake install
}