blob: a23897e57ba1333506225ad9aa4480d81bdde180 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="2bd8130948d3965969ed06fbf77d62270818ddd6"
CROS_WORKON_TREE="6bae1b929d209060122d3f8db9a45fb5c88c14ff"
CROS_WORKON_PROJECT="chromiumos/platform/arc-camera"
CROS_WORKON_LOCALNAME='../platform/arc-camera'
inherit cros-debug cros-workon libchrome toolchain-funcs
DESCRIPTION="ARC camera HALv3 native test."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan"
RDEPEND="
dev-cpp/gtest
media-libs/arc-camera3-libcamera_metadata
media-libs/arc-camera3-libsync
media-libs/libexif
media-libs/minigbm
virtual/jpeg:0"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_compile() {
asan-setup-env
tc-export CC CXX PKG_CONFIG
cros-debug-add-NDEBUG
emake BASE_VER=${LIBCHROME_VERS} camera3_test
}
src_install() {
dobin camera3_test/arc_camera3_test
}