blob: 821704f30f68ee9dcf8d5c7211a2e0e842d54ab7 [file] [log] [blame]
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnome-nettool/gnome-nettool-2.26.2.ebuild,v 1.9 2010/01/18 00:26:14 jer Exp $
EAPI="2"
inherit gnome2 eutils
DESCRIPTION="Collection of network tools"
HOMEPAGE="http://www.gnome.org/projects/gnome-network/"
LICENSE="GPL-2"
SLOT="0"
# FIXME: Dropped ~x86-fbsd (see epatch below)
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
IUSE="debug"
COMMON_DEPEND=">=x11-libs/gtk+-2.6.0:2
>=gnome-base/libglade-2
>=gnome-base/gconf-2
gnome-base/libgtop:2"
RDEPEND="${COMMON_DEPEND}
|| ( net-analyzer/traceroute sys-freebsd/freebsd-usbin )
net-dns/bind-tools
userland_GNU? ( net-misc/netkit-fingerd net-misc/whois )
userland_BSD? ( net-misc/bsdwhois )"
# Gilles Dartiguelongue <eva@gentoo.org> (12 Apr 2008)
# Mask gnome-system-tools 2.14 because it is starting to cause more headache
# to keep it than to mask it.
# Support is autodetected at runtime anyway.
# app-admin/gnome-system-tools
DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.35
>=dev-util/pkgconfig-0.9
app-text/gnome-doc-utils"
DOCS="AUTHORS ChangeLog NEWS README TODO"
pkg_setup() {
G2CONF="${G2CONF}
$(use_enable debug)
--disable-scrollkeeper"
}
src_prepare() {
gnome2_src_prepare
# Doesn't apply, non-trivial to fix => remove fbsd keyword
#epatch "${FILESDIR}"/${PN}-2.18.0-fbsd.patch
# Fix intltoolize broken file, see upstream #577133
sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
}