blob: a3c1b128a387ecc773cd0a877f2f7f72ab296766 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
DESCRIPTION="CodeSourcery's test harness system"
HOMEPAGE="http://www.codesourcery.com/qmtest/"
SRC_URI="http://www.codesourcery.com/public/${PN}/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips ~x86"
IUSE=""
DEPEND=""
RDEPEND=""
pkg_setup() {
python-single-r1_pkg_setup
}
src_install() {
distutils-r1_src_install
find "${D}" -name config.py -print0 | xargs -0 sed -i "s:${D}:/usr:"
rm -r "${D}"usr/share/doc/${PN}/{COPYING,LICENSE.OPL} || die
mv "${D}"usr/share/doc/${PN}/* "${D}"usr/share/doc/${PF} || die
rm -r "${D}"/usr/share/doc/${PN} || die
}