blob: 222883a706e999a94767cfeba2f28a1498a19bb1 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=2
CROS_WORKON_COMMIT="3ce538e93371a56c6ff2d1f7c1b9bd4e7c6873fa"
CROS_WORKON_TREE="232d1b7f856cec143177f017d2f7f8a92599da42"
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME=../third_party/autotest
CROS_WORKON_SUBDIR=files
inherit cros-workon autotest-deponly
DESCRIPTION="Autotest touchpad deps"
HOMEPAGE="http://www.chromium.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="*"
# Autotest enabled by default.
IUSE="+autotest"
AUTOTEST_DEPS_LIST="touchpad-tests"
AUTOTEST_CONFIG_LIST=
AUTOTEST_PROFILERS_LIST=
# NOTE: For deps, we need to keep *.a
AUTOTEST_FILE_MASK="*.tar.bz2 *.tbz2 *.tgz *.tar.gz"
# deps/touchpad-tests
RDEPEND="
x11-drivers/touchpad-tests
chromeos-base/touch_firmware_test
chromeos-base/mttools
"
DEPEND="${RDEPEND}"
src_configure() {
cros-workon_src_configure
}