blob: 3fc9e8c1626ee438855698a7111aa8c2649e4099 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=4
CROS_WORKON_COMMIT="d03de8e4b1ab3eab2bfbb924342b02f176b50b08"
CROS_WORKON_TREE="281c4e1d191b9075aafb7447fb29d80bc74e6d87"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
CROS_WORKON_OUTOFTREE_BUILD=1
inherit cros-workon eutils
DESCRIPTION="Autotest label detector for audio/video/camera"
HOMEPAGE="http://src.chromium.org"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan vaapi"
RDEPEND="vaapi? ( x11-libs/libva )"
DEPEND="${RDEPEND}"
src_unpack() {
cros-workon_src_unpack
S+="/avtest_label_detect"
}
src_prepare() {
cros-workon_src_prepare
}
src_configure() {
export USE_VAAPI=$(usex vaapi)
asan-setup-env
cros-workon_src_configure
}
src_compile() {
cros-workon_src_compile
}
src_install() {
cros-workon_src_install
# Install built tools
pushd "${OUT}" >/dev/null
dobin avtest_label_detect
popd >/dev/null
insinto /etc
doins "${S}"/avtest_label_detect.conf
}