blob: a1e22ce24888fd93c85a0edb0365cff257ae9654 [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="d03de8e4b1ab3eab2bfbb924342b02f176b50b08"
CROS_WORKON_TREE="281c4e1d191b9075aafb7447fb29d80bc74e6d87"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
PLATFORM_SUBDIR="bootstat"
inherit cros-workon platform
DESCRIPTION="Chrome OS Boot Time Statistics Utilities"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="
sys-apps/rootdev
"
DEPEND="${RDEPEND}"
src_install() {
dosbin "${OUT}"/bootstat
dosbin bootstat_archive
dosbin bootstat_get_last
dobin bootstat_summary
dolib.so "${OUT}"/lib/libbootstat.so
insinto /usr/include/metrics
doins bootstat.h
}
platform_pkg_test() {
platform_test "run" "${OUT}/libbootstat_unittests"
}