blob: f20a10bb8ea64e82c9fefdcead65060f445713f4 [file] [log] [blame]
# Copyright (c) 2012 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
CROS_WORKON_COMMIT="d03de8e4b1ab3eab2bfbb924342b02f176b50b08"
CROS_WORKON_TREE="281c4e1d191b9075aafb7447fb29d80bc74e6d87"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
inherit cros-workon
DESCRIPTION="Additional upstart jobs that will be installed on test images"
HOMEPAGE="http://www.chromium.org/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="X"
src_unpack() {
cros-workon_src_unpack
S+="/init"
}
src_install() {
insinto /etc/init
doins upstart/test-init/*.conf
dosbin upstart/test-init/job-filter
insinto /usr/share/cros
doins upstart/test-init/*_utils.sh
use X || rm -f "${D}"/etc/init/vnc.conf
}