blob: 0697bf66e80f2937b1964ae16d8575e01914e2fe [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="d03de8e4b1ab3eab2bfbb924342b02f176b50b08"
CROS_WORKON_TREE="281c4e1d191b9075aafb7447fb29d80bc74e6d87"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_USE_VCSID=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
PLATFORM_SUBDIR="easy-unlock"
inherit cros-workon platform user
DESCRIPTION="Service for supporting Easy Unlock in Chromium OS"
HOMEPAGE="http://www.chromium.org/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="
chromeos-base/easy-unlock-crypto
chromeos-base/libbrillo
"
DEPEND="
${RDEPEND}
chromeos-base/system_api
"
pkg_preinst() {
enewuser easy-unlock
enewgroup easy-unlock
}
src_install() {
exeinto /opt/google/easy_unlock
doexe "${OUT}/easy_unlock"
insinto /etc/dbus-1/system.d
doins org.chromium.EasyUnlock.conf
insinto /usr/share/dbus-1/system-services
doins org.chromium.EasyUnlock.service
insinto /usr/share/dbus-1/interfaces
doins dbus_bindings/org.chromium.EasyUnlockInterface.xml
}
platform_pkg_test() {
platform_test "run" "${OUT}/easy_unlock_test_runner"
}