blob: 878707c4776a727b4987d0323da20de85247b621 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="d03de8e4b1ab3eab2bfbb924342b02f176b50b08"
CROS_WORKON_TREE="281c4e1d191b9075aafb7447fb29d80bc74e6d87"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
PLATFORM_SUBDIR="run_oci"
inherit cros-workon libchrome platform
DESCRIPTION="Utility for running OCI-compatible containers"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="
chromeos-base/libcontainer
"
DEPEND="${RDEPEND}"
src_install() {
cd "${OUT}"
dobin run_oci
}
platform_pkg_test() {
local tests=(
container_config_parser_unittest
)
local test_bin
for test_bin in "${tests[@]}"; do
# platform_test takes care of setting up your test environment
platform_test "run" "${OUT}/${test_bin}"
done
}