blob: cc36fb840ad2b4412bba3c1352785f19a1e54829 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
CROS_WORKON_COMMIT="d03de8e4b1ab3eab2bfbb924342b02f176b50b08"
CROS_WORKON_TREE="281c4e1d191b9075aafb7447fb29d80bc74e6d87"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
inherit cros-debug cros-workon libchrome
DESCRIPTION="Touchpad Experimentation Framework"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan"
RDEPEND="
sys-libs/ncurses
x11-libs/libX11
x11-libs/libXi"
DEPEND="${RDEPEND}
x11-proto/xproto"
src_unpack() {
cros-workon_src_unpack
S+="/salsa"
}
src_configure() {
asan-setup-env
cros-workon_src_configure
}
src_compile() {
cd try_touch_experiment
cros-workon_src_compile
}
src_install() {
cd try_touch_experiment
cros-workon_src_install
default
}