blob: f51a3f81c8bdebfdcf43e42a3d58f9179fe91633 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT=("d03de8e4b1ab3eab2bfbb924342b02f176b50b08" "b02dfadbd697ff664d6b00a595a9c36e7011faf6")
CROS_WORKON_TREE=("281c4e1d191b9075aafb7447fb29d80bc74e6d87" "d9be0d732e5731f9108d886fef705d4d7d0c950a")
CROS_WORKON_LOCALNAME=("platform2" "aosp/system/connectivity/shill")
CROS_WORKON_PROJECT=("chromiumos/platform2" "aosp/platform/system/connectivity/shill")
CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/shill")
inherit cros-workon
DESCRIPTION="shill's test scripts"
HOMEPAGE="http://src.chromium.org"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND="!!chromeos-base/flimflam-test
dev-lang/python
dev-python/dbus-python
dev-python/pygobject"
RDEPEND="${DEPEND}
chromeos-base/shill
net-dns/dnsmasq
sys-apps/iproute2"
src_unpack() {
cros-workon_src_unpack
S+="/platform2/shill"
}
src_compile() {
# We only install scripts here, so no need to compile.
:
}
src_install() {
exeinto /usr/lib/flimflam/test
doexe test-scripts/*
}