blob: 12fc7e38ef4c545fa16dff3e411de5124ea0ddaa [file] [log] [blame]
# Copyright (c) 2011 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="d03de8e4b1ab3eab2bfbb924342b02f176b50b08"
CROS_WORKON_TREE="281c4e1d191b9075aafb7447fb29d80bc74e6d87"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
inherit toolchain-funcs cros-debug cros-workon
DESCRIPTION="TPM SmogCheck library"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
IUSE="-asan"
KEYWORDS="*"
RDEPEND=""
DEPEND="${RDEPEND}
sys-kernel/linux-headers"
src_unpack() {
cros-workon_src_unpack
S+="/smogcheck"
}
src_configure() {
asan-setup-env
cros-workon_src_configure
}
src_compile() {
tc-export CC
cros-debug-add-NDEBUG
emake clean
emake
}
src_install() {
emake DESTDIR="${D}" install
}