blob: a38d73144fb82958c9b9b2d14caa3a4724123e74 [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="3abb4fe45e0e25d203c77d1a5ed1afd49a5a594c"
CROS_WORKON_TREE="6719bec34cef6cd4b99df90e057ce9a1a222fc8a"
CROS_WORKON_PROJECT="chromiumos/platform/vboot_reference"
inherit cros-workon autotest
DESCRIPTION="TPM firmware tests"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 arm amd64"
DEPEND="app-crypt/trousers
chromeos-base/tpm"
# Enable autotest by default.
IUSE="${IUSE} +autotest"
IUSE_TESTS="
+tests_hardware_TPMFirmware
+tests_hardware_TPMFirmwareServer
"
IUSE="${IUSE} ${IUSE_TESTS}"
CROS_WORKON_LOCALNAME=vboot_reference
# path from root of repo
AUTOTEST_CLIENT_SITE_TESTS=autotest/client
AUTOTEST_SERVER_SITE_TESTS=autotest/server
function src_compile {
# for Makefile
export VBOOT_DIR=${WORKDIR}/${P}
export MINIMAL=1 # Makefile requires this for cross-compiling
autotest_src_compile
}