blob: bd0841573f48d6d1834ddd0a43984682503a96ae [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=2
CROS_WORKON_COMMIT="3abb4fe45e0e25d203c77d1a5ed1afd49a5a594c"
CROS_WORKON_TREE="6719bec34cef6cd4b99df90e057ce9a1a222fc8a"
CROS_WORKON_PROJECT="chromiumos/platform/vboot_reference"
inherit cros-workon autotest
DESCRIPTION="vboot tests"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 arm amd64"
# Enable autotest by default.
IUSE="${IUSE} +autotest"
IUSE_TESTS="
+tests_firmware_VbootCrypto
"
IUSE="${IUSE} ${IUSE_TESTS}"
CROS_WORKON_LOCALNAME=vboot_reference
# path from root of repo
AUTOTEST_CLIENT_SITE_TESTS=autotest/client
function src_compile {
# for Makefile
export VBOOT_SRC_DIR=${WORKDIR}/${P}
autotest_src_compile
}