blob: 2bf64e7dd57cb0cc304c423b9faf1e491f04ec6f [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="0f7f6da93f971d90296329b85c1caabf5adce9ef"
CROS_WORKON_TREE="a88f4b6ab6e27887cb1bf68be544e38e50676d4c"
CROS_WORKON_PROJECT="chromiumos/third_party/kernel"
CROS_WORKON_LOCALNAME="kernel/v4.4"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
inherit cros-workon toolchain-funcs
HOMEPAGE="https://www.kernel.org/"
DESCRIPTION="Intel processor C-state and P-state reporting tool"
LICENSE="GPL-2"
SLOT=0
KEYWORDS="*"
IUSE="-asan"
domake() {
emake -C tools/power/x86/turbostat \
BUILD_OUTPUT="$(cros-workon_get_build_dir)" DESTDIR="${D}" \
CC="$(tc-getCC)" "$@"
}
src_configure() {
asan-setup-env
cros-workon_src_configure
}
src_compile() {
domake
}
src_install() {
domake install
}