blob: 0cedba611bc717090dfa1f3aa163fecc0eec3337 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="3a2c61c7d772f869780b625cabca416a64b6b7ab"
CROS_WORKON_TREE="6a81949969aabbfc048cde6b254d2bb368f84364"
CROS_WORKON_PROJECT="chromiumos/platform/frecon"
CROS_WORKON_LOCALNAME="../platform/frecon"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
inherit cros-constants cros-workon toolchain-funcs
DESCRIPTION="Chrome OS KMS console (without DBUS support)"
HOMEPAGE="${CROS_GIT_HOST_URL}/${CROS_WORKON_PROJECT}"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan"
RDEPEND="virtual/udev
media-libs/libpng:0=
sys-apps/libtsm"
DEPEND="${RDEPEND}
media-sound/adhd
virtual/pkgconfig
x11-libs/libdrm"
src_prepare() {
export DBUS=0
export TARGET=frecon-lite
cros-workon_src_prepare
}
src_configure() {
asan-setup-env
cros-workon_src_configure
}
src_compile() {
cros-workon_src_compile
}
src_install() {
cros-workon_src_install
default
}