blob: cafc3d0c70196a6b4b5fbb62810f3ffe088b2a33 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="33b32a5d3992fe35547fdb9539d5b7632405ba71"
CROS_WORKON_TREE=("720cf19b24f85b5cb772bba081aeb033fd4318b4" "3d92ebdaefba405ab87d1aaf23988e9c999d5be3" "dc1506ef7c8cfd2c5ffd1809dac05596ec18773c")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk storage_info .gn"
PLATFORM_SUBDIR="storage_info"
inherit cros-workon platform
DESCRIPTION="Chrome OS storage info tools"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="+mmc nvme +sata test"
DEPEND=""
RDEPEND="${DEPEND}
chromeos-base/chromeos-common-script
!<chromeos-base/chromeos-installer-0.0.3
sata? ( sys-apps/hdparm sys-apps/smartmontools )
nvme? ( sys-apps/smartmontools )
mmc? ( sys-apps/mmc-utils )"
platform_pkg_test() {
platform_test "run" "test/storage_info_unit_test"
}
src_install() {
insinto /usr/share/misc
doins share/storage-info-common.sh
}