blob: 0976b673aab080e2b22c789b3462904d49f0a448 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="33a81c7dfcabc04d8ab5571296bc2f6832ef18fe"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "1811069d8336280067e37e916bf8b24942da00cf" "e8c8ddc463c0f9f733053b2a4a0f6fda2d26c85c" "29d52c6d2464057e3fde8214a173f96d96f3b267" "85d84cce9e70ce5ca50043fc9a74f33b07de86ba" "e8200272d6283e7db5bd02f4007275ee41126c5a")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/include camera/gpu camera/common common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/gpu/tests"
inherit cros-workon platform
DESCRIPTION="Chrome OS camera GPU-related tests"
LICENSE="BSD-Google"
KEYWORDS="*"
BDEPEND="virtual/pkgconfig"
RDEPEND="
chromeos-base/cros-camera-android-deps:=
chromeos-base/cros-camera-libs:=
dev-cpp/gtest:=
virtual/opengles:=
"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers:=
"
src_configure() {
cros_optimize_package_for_speed
platform_src_configure
}
src_install() {
dobin "${OUT}"/image_processor_test
platform_src_install
}