blob: 4bc28e2771158eb7c048550cf2e09ba0bcfb5f7f [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="8d67e0f54da73caa77809f6d36027931898702b8"
CROS_WORKON_TREE="5f68ff3299f59bac377f249a17802262168a3c3c"
CROS_WORKON_PROJECT="chromiumos/third_party/coreboot"
DESCRIPTION="lp0 resume blob for Tegra"
HOMEPAGE="http://www.coreboot.org"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* arm arm64"
IUSE=""
RDEPEND=""
DEPEND=""
CROS_WORKON_LOCALNAME="coreboot"
inherit cros-workon
src_compile() {
emake -C src/soc/nvidia/tegra210/lp0 \
GCC_PREFIX="${CHOST}-" || \
die "tegra_lp0_resume build failed"
}
src_install() {
insinto /lib/firmware/nvidia/tegra210/
doins src/soc/nvidia/tegra210/lp0/tegra_lp0_resume.fw
# Also install into /firmware so it can be picked up for signing
insinto /firmware
doins src/soc/nvidia/tegra210/lp0/tegra_lp0_resume.fw
}