blob: de6c97d9c61d4bed65547b59ce59558c08f90803 [file] [log] [blame]
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="nl80211-based configuration utility for wireless devices using the mac80211 kernel stack"
HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/iw"
SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="dev-libs/libnl"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
default
tc-export CC LD PKG_CONFIG
}
src_compile() {
CFLAGS="${CFLAGS} ${CPPFLAGS}" \
LDFLAGS="${CFLAGS} ${LDFLAGS}" \
emake V=1
}
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}