blob: bac96c2e3f501588fbafa9f580b65351297aaaf6 [file] [log] [blame]
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.10-r1.ebuild,v 1.1 2010/01/20 07:30:56 robbat2 Exp $
EAPI=2
inherit eutils
DESCRIPTION="A file archival tool which can also read and write tar files"
HOMEPAGE="http://www.gnu.org/software/cpio/cpio.html"
SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="nls"
src_prepare() {
# Per here: http://lists.gnu.org/archive/html/bug-cpio/2009-10/msg00000.html
# fixes hardlink creation from XFS
epatch "${FILESDIR}"/cpio-2.9-64-bit-wide-inode-fixup.patch
}
src_configure() {
econf \
$(use_enable nls) \
--bindir=/bin \
--with-rmt=/usr/sbin/rmt \
|| die
}
src_compile() {
emake || die
}
src_install() {
emake install DESTDIR="${D}" || die
dodoc ChangeLog NEWS README
rm -f "${D}"/usr/share/man/man1/mt.1
rmdir "${D}"/usr/libexec || die
}