blob: 2c18f8acb5a7cf658d350c0b71a6231ea62d4e0b [file] [log] [blame]
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.10.ebuild,v 1.1 2009/06/20 10:20:01 vapier Exp $
DESCRIPTION="A file archival tool which can also read and write tar files"
HOMEPAGE="http://www.gnu.org/software/cpio/cpio.html"
SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="nls"
src_compile() {
econf \
$(use_enable nls) \
--bindir=/bin \
--with-rmt=/usr/sbin/rmt \
|| die
emake || die
}
src_install() {
emake install DESTDIR="${D}" || die
dodoc ChangeLog NEWS README
rm -f "${D}"/usr/share/man/man1/mt.1
rmdir "${D}"/usr/libexec || die
}