blob: 2f7ea238bcf3a5be33a3e32679b50fc8e807f4e3 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="A simple statsd client"
HOMEPAGE="https://github.com/jsocol/pystatsd http://pypi.python.org/pypi/statsd"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RDEPEND=""
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
)"
python_test() {
nosetests --verbose || die
}