blob: ae8a92d6a1fecb6b0f40621339079eebaba4162a [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
GNOME2_LA_PUNT="yes"
inherit flag-o-matic gnome2
DESCRIPTION="A window navigation construction kit"
HOMEPAGE="https://developer.gnome.org/libwnck/stable/"
LICENSE="LGPL-2+"
SLOT="3"
KEYWORDS="alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="+introspection startup-notification tools"
RDEPEND="
x11-libs/cairo[X]
>=x11-libs/gtk+-3.16:3[introspection?]
>=dev-libs/glib-2.32:2
x11-libs/libX11
x11-libs/libXres
x11-libs/libXext
introspection? ( >=dev-libs/gobject-introspection-0.6.14:= )
startup-notification? ( >=x11-libs/startup-notification-0.4 )
x86-interix? ( sys-libs/itx-bind )
"
DEPEND="${RDEPEND}
dev-util/gtk-doc-am
>=dev-util/intltool-0.40.6
sys-devel/gettext
virtual/pkgconfig
"
# eautoreconf needs
# gnome-base/gnome-common
src_configure() {
if use x86-interix; then
# activate the itx-bind package...
append-flags "-I${EPREFIX}/usr/include/bind"
append-ldflags "-L${EPREFIX}/usr/lib/bind"
fi
# Don't collide with SLOT=1
gnome2_src_configure \
--disable-static \
$(use_enable introspection) \
$(use_enable startup-notification) \
$(use_enable tools) \
--program-suffix=-${SLOT}
}