blob: 37b20e4599f609d37b8f42298d623409ed7667c0 [file] [log] [blame]
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/swh-plugins-0.4.15.ebuild,v 1.6 2008/10/05 11:31:01 aballier Exp $
inherit eutils autotools
DESCRIPTION="Large collection of LADSPA audio plugins/effects"
HOMEPAGE="http://plugin.org.uk"
SRC_URI="http://plugin.org.uk/releases/${PV}/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ~ppc x86"
IUSE="3dnow nls sse"
RDEPEND="media-libs/ladspa-sdk
>=sci-libs/fftw-3"
DEPEND="${RDEPEND}
sys-devel/gettext
dev-util/cvs
dev-util/pkgconfig"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-pic.patch"
epatch "${FILESDIR}/${P}-plugindir.patch"
epatch "${FILESDIR}/${P}-riceitdown.patch"
epatch "${FILESDIR}/${P}-gettext.patch"
# This is to update gettext macros, otherwise they are incompatible with
# recent libtools, bug #231767
autopoint -f || die
# it doesn't get updated otherwise
rm -f missing
eautoreconf
elibtoolize
}
src_compile() {
econf ${myconf} \
$(use_enable sse) \
$(use_enable 3dnow) \
$(use_enable nls) \
$(use_enable userland_Darwin darwin) \
--enable-fast-install \
--disable-dependency-tracking || die "econf failed"
emake || die "emake failed."
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS ChangeLog README TODO
}
pkg_postinst() {
ewarn "WARNING: You have to be careful when using the"
ewarn "swh plugins. Be sure to lower your sound volume"
ewarn "and then play around a bit with the plugins so"
ewarn "you get a feeling for it. Otherwise your speakers"
ewarn "won't like that."
}