blob: 3ecb0b9ee4a0efd78c85786efa61adbfe21aaef6 [file] [log] [blame]
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceroute/traceroute-2.0.11.ebuild,v 1.8 2008/09/19 00:11:10 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils
DESCRIPTION="Utility to trace the route of IP packets"
HOMEPAGE="http://traceroute.sourceforge.net/"
SRC_URI="mirror://sourceforge/traceroute/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
IUSE="static"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${PN}-2.0.8-prestrip.patch"
}
src_compile() {
use static && append-ldflags -static
tc-export CC AR RANLIB
emake env=yes || die
}
src_install() {
emake \
DESTDIR="${D}" \
prefix="/usr" \
libdir="/usr/$(get_libdir)" \
install \
|| die
dodoc ChangeLog CREDITS README TODO
}