blob: 33af867f1f15ac9807834914a4f78c7285bb2fb1 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
PHP_EXT_NAME="eio"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS=( README.md )
USE_PHP="php5-5 php5-6 php7-0"
inherit php-ext-pecl-r3
KEYWORDS="~amd64 ~x86"
LICENSE="PHP-3.01"
DESCRIPTION="PHP wrapper for libeio library"
LICENSE="PHP-3"
SLOT="0"
IUSE="debug"
src_configure() {
local PHP_EXT_ECONF_ARGS="--with-eio $(use_enable debug eio-debug)"
php-ext-source-r3_src_configure
}